Gimp nach Upgrade auf Xubuntu 20.04

Das Xubuntu meines PCs habe ich über Jahre immer wieder “hochgezogen”, nie neu aufgesetzt. Das hat auch immer fast reibungslos funktioniert. Nun aber hatte ich Schwierigkeiten mit GIMP – es startete einfach nicht mehr und zeigte dabei eine unerwartete Fehlermeldung.

Das ließ sich auch durch einen Blick in Synaptic prüfen. Das Problem bestand also nun darin, wie ich GEGL erneuern sollte. Versuche, GIMP über Snap oder Flatpak zu installieren, haben zwar funktioniert, hatten aber eben auch die Nachteile von Snap oder Flatpak: viel Speicherverbrauch und ein umständlicher Mechanismus dahinter. Außerdem kann ein über Snap installiertes GIMP aus Sicherheitsgründen nicht auf Dateien in /tmp zugreifen, was aber für die sofortige Verarbeitung von Screenshots mit xfce4-screenshooter nötig wäre.

Zum Glück bin ich nicht mehr der Einzige mit dem Problem. Fragen an die Fachleute in Newsgroups brachten leider kein nutzbares Ergebnis, aber hier wurde genau mein Problem beschrieben und eine funktionierende Lösung gezeigt:

forum.ubuntuusers.de/topic/probleme-mit-gimp-3/#post-9165196

(Danke an die dort Diskutierenden!)

Vor dem Upgrade auf Xubuntu 20.04 hatte ich das PPA für GIMP benutzt, dann deaktiviert und schließlich gelöscht – aber das führte offenbar zu irgendwelchen Paketfehlern, die nicht einfach mit “apt install -f” gelöst werden konnten. Erst ppa-purge brachte letztlich die Lösung, was man aber erst mittels “apt install ppa-purge” installieren muss. Dann deaktiviert und löscht man das PPA “gründlich”:

sudo ppa-purge ppa:otto-kesselgulasch/gimp

Dann lässt sich GIMP ganz normal und funktionierend mit “apt install gimp” installieren. Die Anleitung unter launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp bzw. das PPA selbst scheint für Ubuntu 20.04 (noch) nicht zu funktionieren. Jetzt ist in Synaptic auch libgegl-0.4.22 sichtbar, wo vorher 0.4.18 stand.

Wie üblich muss man noch die Hilfe gimp-help-de und bei Bedarf andere Plugins wie gimp-dcraw nachinstallieren.

2 Gedanken zu „Gimp nach Upgrade auf Xubuntu 20.04

  1. Bernd

    Hallo , soweit habe ich es ebenso hinbekommen.Wie hier beschieben.
    Habe aber leider imme noch das Problem , das unter Gimp der Druck mit Gutenberg-Print nicht funktioniert und auch im geöffneten Fenster man nicht auf Farbe umstellen kann.Ist zwar egal, weil es sowieso nicht druckt!

    Vielleicht hat jemand eine Idee, wie man es wieder zum laufen bekommt.
    Unter Ubuntu 18.04 lief es einwandfrei.

    LG Bernd

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.